Upgrade JNR to allow usage in OSGI

Description

JNR is currently excluded in OSGI, because its artifacts don't have proper descriptors.

This is a reminder that we need to upgrade it once the following pull requests have made it into a stable release:

See also: https://github.com/datastax/java-driver/pull/591#issuecomment-192091559

Environment

None

Pull Requests

None

Activity

Show:
Andy Tolbert
March 18, 2016, 2:09 PM

A version of jffi (1.2.11) was recently released with OSGi support, so now we are just waiting on jnr-x86asm.

Alexandre Dutra
June 21, 2020, 5:11 PM

This ticket has been closed due to more than 2 years of inactivity, as part of an automatic housekeeping procedure.

If you think that this was inappropriate, feel free to re-open the ticket. If possible, please provide any context that could explain why the issue described in this ticket is still relevant.

Thanks for your understanding.

Assignee

Unassigned

Reporter

Olivier Michallat

Labels

PM Priority

None

Affects versions

Fix versions

None

Pull Request

None

Doc Impact

None

Size

None

External issue ID

None

External issue ID

None

Priority

Major
Configure