Document issues that can arise out of incompatible agents and libraries

Description

Hi,

We are using DataStax driver 3.1.0 to connect to Cassandra 2.1.3 server. Everything is working fine on all environments except the one which has dyna trace agent enabled. Same query and code which works on non dyna trace environment, gives below issue on environment where agent is enabled.

Environment

Linux having dyna trace enabled

Pull Requests

None

Activity

Show:
Andy Tolbert
January 27, 2017, 9:03 PM

I think the issue with this is that the Dynatrace agent targets version 2.1 of the driver (see supported versions here). It needs to be updated by Dynatrace to support 3.0 and 3.1. I'll work to add a FAQ to the driver docs using this ticket as a basis.

Nitin Agarwal
January 27, 2017, 9:11 PM

Thanks Andy for quick response. So basically, I need to update Dyna Trace agent profile to point to 3.0 version of driver?
Do we have 3.0 support for dyna trace?

Andy Tolbert
February 22, 2018, 4:55 PM
Edited

My apologies for the very late reply. From what I can tell in DynaTrace documentation, there are no versions of the agent which support java driver 3.0+ unfortunately.

I've created a PR that documents issues that can arise out of incompatible agents and libraries which I think will help users diagnose issues like these in the future.

Fixed

Assignee

Unassigned

Reporter

Nitin Agarwal

Labels

PM Priority

A

Affects versions

Fix versions

Pull Request

None

Doc Impact

None

Size

None

External issue ID

None

External issue ID

None

Components

Priority

Major
Configure