Fix column names in EntityHelper.updateByPrimaryKey

Description

EntityHelperUpdateByPrimaryKeyMethodGenerator.java

Since JAVA-2110, property.getCqlName() is a code block, so it should be injected with $2L, not $2S (two occurrences to replace).

The current version will generate a case-sensitive identifier if a built-in naming convention is in use, and garbage for a custom name converter.

Environment

None

Pull Requests

None

Status

Assignee

Olivier Michallat

Reporter

Olivier Michallat

Labels

None

PM Priority

None

Reproduced in

None

Affects versions

None

Fix versions

Pull Request

None

Doc Impact

None

Size

None

External issue ID

None

External issue ID

None

Priority

Minor
Configure