Mention Java version compatibility in root README

Description

There's a note about it in the upgrade guide, but it should be displayed more prominently on the home page.

Environment

None

Pull Requests

None

Status

Assignee

Unassigned

Reporter

Olivier Michallat

Labels

None

PM Priority

None

Affects versions

None

Fix versions

Pull Request

None

Doc Impact

None

Size

None

External issue ID

None

External issue ID

None

Priority

Trivial
Configure