Invalid or unsupported protocol version for 4.2.1 Java Driver

Description

We are getting errors with "unsupported protocol version" from Cassandra.
This is happening more in high-load condition.

Error details:

We are using driver 4.2.1 and we tried with setting the protocol version explicitly to 4 as well.

We also tried not setting the protocol and letting the driver negotiate with the cluster. In both cases its the same error that's happening.

What is even more confusing is how the version is getting set to 15, 69 etc.

Environment

None

Pull Requests

None

Status

Assignee

Olivier Michallat

Reporter

Nashid Noor

Labels

None

PM Priority

None

Reproduced in

4.2.1

External issue ID

None

External issue ID

None

External issue ID

None

External issue ID

None

External issue ID

None

External issue ID

None

Doc Impact

None

Reviewer

None

Size

None

Fix versions

Affects versions

4.2.1

Priority

Blocker
Configure