Upgrade guava dependency to 16.x

Description

We have clients that want to update to Guava 16 from 14 because of Hadoop CDH5. However java-driver is still at 14.0.1 with following comments in pom.xml.

We use an old version of Guava to be compatible with Spark 1.1.
Check with the spark-cassandra-connector team before upgrading this.

Can we upgrade guava to 16 in java-driver?

Environment

None

Pull Requests

None

Activity

Show:
RaghunathN
June 23, 2015, 3:04 AM

Yes ..

On Mon, Jun 22, 2015, 10:03 PM Alex Popescu (JIRA) <

Alex Popescu
June 23, 2015, 3:02 AM

Can this be closed?

RaghunathN
June 10, 2015, 10:59 PM

I am using Glassfish 4.1. I found that the internals of glassfish server are using Guava. It's the root cause of the issue. Even after overriding the problem still persists as the Guava Futures are been executed Asynchronously. Trying to shift to Jboss
thank you for the quick update

Andy Tolbert
June 10, 2015, 10:56 PM
Edited

, if you are using maven, you can explicitly force Guava 18 by adding it as a dependency under your dependencies section:

Otherwise if you are using another build tool/environment, you will need to use it's mechanism for adding jar dependencies (like putting the jar file in your classpath, putting it in a directory, etc.).

RaghunathN
June 10, 2015, 9:56 PM

Please provide steps to override Guava 14 -> 18. Or integration suite link.
Thank you.

Not a Problem

Assignee

Unassigned

Reporter

Vishy Kasar

Labels

None

PM Priority

None

Affects versions

Fix versions

None

Pull Request

None

Doc Impact

None

Size

None

External issue ID

None

External issue ID

None

Components

Priority

Major