Drop support for Node.js 4 and 6 runtime

Description

Node.js 4 reached EOL in April 2018:
https://github.com/nodejs/Release

Dropping support for Node.js 4 allows us to remove quirks in the build process (like the old eslint dependency) and use more modern JavaScript features like Destructuring assignment and spread syntax.

Environment

None

Pull Requests

None

Activity

Show:
Jorge Bay Gondra
January 9, 2020, 1:16 PM

Done as part of NODEJS-574.

Fixed

Assignee

Unassigned

Reporter

Jorge Bay Gondra

Reviewer

None

Fix versions

Labels

None

Components

None

PM Priority

None

Pull Request

None

Epic Link

Priority

Major