gremlinpython 3.3.8 is not compatible with DSE 5.1

Description

none() step gets added with the call to iterate() as a server side filter step. This is not compatible with the tinkerpop version of DSE 5.1.

To support all dse versions, we have to downgrade this dependency to gremlinpython 3.3.4.

Environment

None

Pull Requests

None

Status

Assignee

Unassigned

Reporter

Alan Boudreault

Fix versions

Labels

None

Reproduced in

None

PM Priority

None

External issue ID

None

Doc Impact

None

Reviewer

None

Size

None

Components

Priority

Critical
Configure