Use 4.0 schema parser in 4 alpha and snapshot builds

Description

The Version comparison considers snapshots and alpha to be before the main release so 4.0 features wont work with cqlsh until GA which kinda invalidates a lot of the testing. The schema parser choice should change to cover all possible 4.0 release.

Environment

None

Status

Assignee

Unassigned

Reporter

Chris Lohfink

Fix versions

Labels

Reproduced in

3.19.0

PM Priority

None

External issue ID

None

External issue ID

None

External issue ID

None

External issue ID

None

External issue ID

None

External issue ID

None

Doc Impact

None

Reviewer

None

Size

None

Affects versions

3.19.0

Priority

Major
Configure