Make geomet an optional dependency at runtime

Description

If geomet is not available at runtime, just ignore it. An error should be raised only if geomet is not available and a user is trying to use geo types.

This ticket will also help maintaining and upgrading the driver in older cassandra dev branches. (like https://issues.apache.org/jira/browse/CASSANDRA-15663)

Environment

None

Pull Requests

None
Fixed

Assignee

Unassigned

Reporter

Alan Boudreault

Fix versions

Labels

None

PM Priority

None

External issue ID

None

Doc Impact

None

Reviewer

None

Size

None

Pull Request

None

Priority

Minor