DSE Driver version checking

Description

DSE driver will be updated in its core driver version specification

1.) Version range is [current min with supporting features] <= req < [next major]
2.) Expose a way in DSE driver to provide both core and DSE versions
3.) Put a dynamic version check and blow up or warn if the installed core exceeds that

Environment

None

Pull Requests

None

Activity

Show:
Alex Popescu
May 25, 2016, 2:16 AM

, , , : this applies to all drivers which declare a dependency on the core driver:

1. use a [min, max) version dependency
2. provide an internal check for the correctness of the version (some dependency managers might not enforce this and even if enforced they won't catch manual updates)
3. in an attempt to help support, the DSE drivers should provide a way to retrieve both the core and DSE versions (a function, a log entry, etc.)

Alan Boudreault
June 14, 2016, 10:47 PM
Greg Bestland
June 16, 2016, 6:19 AM
Fixed

Assignee

Unassigned

Reporter

Adam Holmberg

Fix versions

None

Labels

PM Priority

None

External issue ID

None

Doc Impact

None

Reviewer

None

Size

None

Pull Request

None

Components

Priority

Major