Limit PHP versions to officially supported PHP version

Description

Limit PHP versions to currently supported versions.

  • v7.2.x (EOSL 30-11-2020)

  • v7.3.x (EOSL 06-12-2021)

  • v7.4.x (EOSL 28-11-2022)

Note: This includes removing support for all older versions of PHP, updating the submodule to point to the latest cpp-driver release, and ensures builds on linux.

Environment

None

Pull Requests

None

Assignee

Michael Fero

Reporter

Michael Fero

Labels

None

PM Priority

None

External issue ID

None

Doc Impact

None

Reviewer

None

Pull Request

None

Size

None

Fix versions

Priority

Major
Configure